Results 1 to 3 of 3
  1. #1
    Join Date
    May 2012
    Location
    Arizona
    Posts
    4
    Thanks
    0
    Thanked 0 Times in 0 Posts
    Rep Power
    0

    Default New to site, have problem with engine kit!

    Hi, i'm Arnold.
    I recently bought a 4G bike engine kit from pirate cycles, to make our schwinn jaguar motorized.
    The everything is installed correctly, and when we went to go on our maiden voyage, the bike went nowhere.
    The engine seems to work fine, and the clutch engages, but the chain never turns. I did some troubleshooting and found that the one-way bearing in the freewheel is completely stripped out. I've attached a photo.

    What should I do?
    I've emailed pirate cycles for about 2 weeks with no response, and the phone number on their website goes straight to a voicemailbox that is already full.

    Thanks in advance for any help!
    Attached Images Attached Images  

  2. #2
    Join Date
    Apr 2012
    Location
    Tunkhannock, Pa
    Age
    50
    Posts
    151
    Thanks
    0
    Thanked 0 Times in 0 Posts
    Rep Power
    3

    Default

    May want to just cut your losses with Pirate cycles. Here may be what you need to get back up and running. http://www.kingsmotorbikes.com/bike-...ke-bearing.htm


  3. #3
    Join Date
    May 2009
    Location
    Florida's SW Coast
    Posts
    969
    Thanks
    0
    Thanked 0 Times in 0 Posts
    Rep Power
    6

    Default

    Welcome to MBc, Arnold. I would say that, for $10.00, Lunardog seems to have the answer to your problem. And, if pirate ever does come thru with a replacement, you'll have a spare.

    Patrick
    Modified Trailmate Meteor Delta Trike, 21 pedal gears, Robin-Subaru EH035 w/Staton-Inc gear box. Plus 40 mph (stable) -- Hide & Watch.

Similar Threads

  1. [Engine Trouble] engine problem
    By scbiker in forum 2-Stroke Motorized Bicycle Engines
    Replies: 8
    Last Post: 02-04-2014, 04:02 AM
  2. New Engine-problem
    By james65 in forum 2-Stroke Motorized Bicycle Engines
    Replies: 2
    Last Post: 03-23-2011, 08:05 PM
  3. Problem getting spindle on engine
    By kbanta11 in forum 2-Stroke Motorized Bicycle Engines
    Replies: 1
    Last Post: 08-13-2008, 12:25 AM
  4. Engine Problem!!! In need of some help!
    By StrontiumEthics in forum 2-Stroke Motorized Bicycle Engines
    Replies: 2
    Last Post: 08-11-2008, 06:59 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •